Discussions

General J2EE: Connecting Weblogic 6 and above from JDeveloper

  1. Connecting Weblogic 6 and above from JDeveloper (8 messages)

    When I try to connect to Weblogic 6 from Oracle 9i JDeveloper and try to Test the connection it gives me a "Connection Exception" stating "Cannot instantiate class: weblogic.jndi.WLInitialContextFactory",even though I have specified correct path for Weblogic.jar.What can be the reason for this??
  2. I don't know the answer (I get the same).

    However, the production version of JDeveloper 9.0.3 has just been released, so maybe it's fixed in there.

    I'll download this weekend.

    Cheers,
    Rick
  3. Hi Richard Kenyon

    Eurekaaaaaaaaaaaaaaaaa
    first step put weblogic.jar \jdev\jdev\lib\ext\weblogic.jar
    After that rename this jar jaas.jar which you will get in ..\jdev903\j2ee\home\lib e.g. jaas1.jar.
    Restart the Jdeveloper ...and shout Eurekaaaaa
    ---Rakesh Sharma
  4. Did you put weblogic.jar in C:\jdev\jdev\lib\ext folder??
  5. Thanks for ur suggestion.Actually I have put the weblogic.jar in the folder u mentioned but still it does not work.
  6. Try with JDev10g it works fine! at least with our BEA Weblogic 8.1
  7. As mentioned put weblogic.jar in C:\jdev\jdev\lib\ext

    and then, don't forget to re-start JDev
    The (java)\lib\ext stuff is all loaded up at start-time
  8. I am also getting the same problem even i put weblogic.jar in D:\jdev903\jdev\lib\ext and restarted the Jdeveloper but still its showing "weblogic.jndi.WLInitialContextFactory" .
    can somebudy help me??
  9. I want to use JDeveloper 10g for development , Test run and debug the application with Weblogic Server(6.1) (I do not want the embedded OC4j server).I already created connection for weblogic, in JDeveloper ,but for every change i have to deploy the war file sepratly in app server.