struts1.1 doesn't work in weblogic7.0,need help,many thanks

Discussions

General J2EE: struts1.1 doesn't work in weblogic7.0,need help,many thanks

  1. there's an j2ee project,needs struts for web framework and ejb for web logic application.
        how can they work together in weblogic7.0.

        i modified the startWLS.cmd and added the struts.jar to the classpath,but found the struts didn't work correctly in the weblogic7.0,neither the struts project i developed with jbuilder nor the struts-example in the tomcat/struts-webapps.


    Error 500--Internal Server Error
    From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
    10.5.1 500 Internal Server Error
    The server encountered an unexpected condition which prevented it from fulfilling the request.


        do not tell me the suggestion is to use the tomcat to run the struts and the weblogic to run the ejb,because i will cry~~~~~~~~.
    5555555555555

        some one help me,with many thanks
  2. The kind souls who developed Struts have already provided the documentation on how to install Struts.

    Would not suggest you to use Tomcat and Weblogic cuz Weblogic should suffice.

    Refer http://jakarta.apache.org/struts/userGuide/installation.html
     for pointers.

    And by the way , do brush up on your understanding of deploying web applications.
  3. Hello Fu,

    You don't put the struts.jar file on the classpath. Apache spefically mentions this. struts.jar should be in the WEB-INF/lib directory of your web application.

    You could download the samples of struts 1.1 and deploy it on weblogic 7.0 and see how the application is written.

    David Lee