Discussions

General J2EE: Configuring MQSeries with LDAP

  1. Configuring MQSeries with LDAP (7 messages)

    Hi,

    Can any one help me out how I can configure Websphere MQ with LDAP server?

    Thanks in advance
    Satya

    Threaded Messages (7)

  2. Satya;
    First thing you need to do is configure JMSAdmin. Go to <WebSphereMQHome>/java/bin and edit the JMSAdmin.config file.
    The important parts are:
    INITIAL_CONTEXT_FACTORY=com.sun.jndi.ldap.LdapCtxFactory
    PROVIDER_URL=ldap://<your host>:389/<root dn>The root dn will be something like "o=ibm,c=us".
    SECURITY_AUTHENTICATION=simple
    PROVIDER_USERDN=cn=Directory Manager
    PROVIDER_PASSWORD=<password>

    Once you have that working, you should be able to run JMSAdmin.[bat][ksh] etc. If it works, you will see something like this:


    ========================
    5648-C60, 5724-B41, 5655-F10 (c) Copyright IBM Corp. 2002. All Rights Reserved.
    Starting Websphere MQ classes for Java(tm) Message Service Administration


    InitCtx>
    ========================

    Now you can create connection factories, topics and queues using the JMSAdmin commands. These are summarized here:
    http://www-3.ibm.com/software/ts/mqseries/library/manualsa/csqzaw04/csqzaw13.htm#HDRJMS77H2

    For example, to create a queue connection factory you would do this:

    DEFINE QCF(MyQCF)

    Also, it helps to have a good LDAP browser. I recommend this one: http://www.iit.edu/~gawojar/ldap/

    Cheers.

    //Nicholas
  3. Hi Nicholas,

    Thanks for information.

    I have done the same thing and able to see the below:


    ========================
    5648-C60, 5724-B41, 5655-F10 (c) Copyright IBM Corp. 2002. All Rights Reserved.
    Starting Websphere MQ classes for Java(tm) Message Service Administration


    InitCtx>
    ========================



    Here, when I issue a command to create a queue or context it is saying "unable to bind".

    I am using Webspehre MQ 5.3 (trail version).

    Thank You,
    Satya
  4. Satya;

    I would tail the output of the access and/or error logs of your LDAP server while you do this operation and see what the error is. If you see no activity (and judging by the error message) you did not successfully bind to the LDAP server.

    If you determine this is the case, review the settings. If you see absolutely no activity in your logs when you try to bind, then the server is not even being reaches, so your host name and/or port number are probably wrong.

    //Nicholas
  5. Hi Nicholas,

    Thank you, the problem is got resolved.

    I was giving wrong provider url in the config file.

    Satya
  6. Hi ,

    I am trying to integrate Weblogic and MQ through JMS.
    I am defining Weblogic Foreign JMS Server and try to use MQ under the cover.
    To access MQ, I need to provide the Context Factory and URL. I know the options are file or LDAP.

    My Question is:

    I have installed MQ Series 5.3 and Weblogic 8.1
    (Keep in mind that I have only these two softwares installed, I dont have any LDAP or JNDI server).
    Now, How do I make it work?

    Thanks in Advance,
    Idhaya
  7. Configuring MQSeries with LDAP[ Go to top ]

    Hi nicholas,

    I am very new to websphere mq. I have installed mqv7.5 on windows 2008 std edition. I have created a group domiain mqm and added 2 users ( namely Deep & Diddi) to it and granted the read group info permission to the whole group. Enabled LDAP on windows 2008. The FQDN for windows 2008 on which mq is running is second.kind.com.

    Now coming to editing the jmsadmin conf file, i took out # in the front of INITIAL_CONTEXT_FACTORY=com.sun.jndi.ldap.LdapCtxFactory and other intial_context_factories have a # in front of them.

    Now coming to PROVIDER_URL=ldap://<your host>:389/<root dn>,,, i gave ldap://second.l7tech.com:389/dc=kind,dc=com

    SECURITY_AUTHENTICATION=simple

    PROVIDER_USERDN=cn=Deep,dc=kind,dc=com

    PROVIDER_PASSWORD=<password>( respective password for user deep which i gave in AD while creation)

    After this i tried to click on jmsadmin.bat, the window opens up and closes automatically, but if i use the default jmsadmin conf file, i mean the one without doing the above changes the windows open up and stays and i can see the prompt  InitCtx>

    Please kindly help me with  where am i going wrong as i am trying to get this work for more than 4 weeks now.

     

    Thanks & Regards,

    Deep

     

  8. Configuring MQSeries with LDAP[ Go to top ]

    Hi nicholas,

    I made a mistake in my previous post , for PROVIDER_URL=ldap://<your host>:389/<root dn>,,, i gave ldap://second.kind.com:389/dc=kind,dc=com