Discussions

Web tier: servlets, JSP, Web frameworks: hello, please help me !

  1. hello, please help me ! (1 messages)

    i have a project which was developed in jb8+struts1.02 .

    now i want to upgrade it to struts1.1-rc1 version.

    first i upgrade struts version to 1.1 in jbuilder 8.
    then i load my project in jbuilder8 and build it successfully.

    but when i run, it has error like this :

    java.lang.ClassNotFoundException:
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1428)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1274)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3217)
    at org.apache.catalina.core.StandardContext.start(StandardContext.java:3524)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:821)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:807)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:579)
    at org.apache.catalina.core.StandardHostDeployer.addChild(StandardHostDeployer.java:529)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.apache.commons.beanutils.MethodUtils.invokeMethod(MethodUtils.java:228)
    at org.apache.commons.digester.SetNextRule.end(SetNextRule.java:260)
    at org.apache.commons.digester.Digester.endElement(Digester.java:1036)
    at org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1536)
    at org.apache.crimson.parser.Parser2.parseInternal(Parser2.java:500)
    at org.apache.crimson.parser.Parser2.parse(Parser2.java:305)
    at org.apache.crimson.parser.XMLReaderImpl.parse(XMLReaderImpl.java:442)
    at org.apache.commons.digester.Digester.parse(Digester.java:1514)
    at org.apache.catalina.core.StandardHostDeployer.install(StandardHostDeployer.java:335)
    at org.apache.catalina.core.StandardHost.install(StandardHost.java:803)
    at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:452)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:409)
    at org.apache.catalina.startup.HostConfig.start(HostConfig.java:879)
    at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:368)
    at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:166)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1196)
    at org.apache.catalina.core.StandardHost.start(StandardHost.java:738)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1188)
    at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:347)
    at org.apache.catalina.core.StandardService.start(StandardService.java:497)
    at org.apache.catalina.core.StandardServer.start(StandardServer.java:2189)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:510)
    at org.apache.catalina.startup.Catalina.execute(Catalina.java:400)
    at org.apache.catalina.startup.Catalina.process(Catalina.java:180)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:203)
    StandardContext[/mystruts]: Skipped installing application listeners due to previous error(s)
    StandardContext[/mystruts]: Context startup failed due to previous errors


    anyone help me please, thanks !
  2. hello, please help me ![ Go to top ]

    Hi,

    Seems you are having some problesm migrating to struts 1.1.
    I believe some jar which are required by struts are not available.Why don't you download the struts package once again and deploy your application.Check that your struts-confix andweb xml files are wellformed.

    Cheers
    VIJAY