Discussions

General J2EE: Eclipse exception on my first use

  1. Eclipse exception on my first use (1 messages)

    I don't know where to post this message, so I choose to post it here. If I disturb you, I say sorry to you.

    this exception occurs on my first use of eclipse, i am confused with it. the messages below is in the .log file of eclipse:
    !SESSION ----------------------------------------------------------------------
    !ENTRY org.eclipse.core.launcher 4 0 六月 19, 2003 10:45:32.956
    !MESSAGE Exception launching the Eclipse Platform:
    !STACK
    java.lang.ExceptionInInitializerError
    at org.eclipse.core.internal.runtime.InternalPlatform.loadRegistry(InternalPlatform.java:646)
    at org.eclipse.core.internal.runtime.InternalPlatform.loaderStartup(InternalPlatform.java:562)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.eclipse.core.internal.boot.InternalBootLoader.startup(InternalBootLoader.java:965)
    at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:824)
    at org.eclipse.core.boot.BootLoader.run(BootLoader.java:462)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:247)
    at org.eclipse.core.launcher.Main.run(Main.java:703)
    at org.eclipse.core.launcher.Main.main(Main.java:539)
    Caused by: java.util.MissingResourceException: Can't find bundle for base name org.eclipse.core.internal.runtime.messages, locale zh_CN
    at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:804)
    at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:773)
    at java.util.ResourceBundle.getBundle(ResourceBundle.java:538)
    at org.eclipse.core.internal.runtime.Policy.<clinit>(Policy.java:19)
    ... 16 more

    at first i considered that maybe something is wrong with my eclipse, but later i found that it repeates in every version of the eclipse that i have. can somebody help me? thanks a lot. or maybe somebody can tell me where to find the solution...

    p.s.: i am on win2k pro platform, and it also occurs on win2003 server platform...jdk is v1.4, eclipse version: 2.0.2, 2.1, M1...:)
  2. What's your locale? Try starting Eclipse in "English(United States)" locale.