Has anyone successfully ran the new J2EE SDK 1.4 on Windows?

Discussions

General J2EE: Has anyone successfully ran the new J2EE SDK 1.4 on Windows?

  1. I have installed Sun's new J2EE SDK 1.4 on both Windows XP and Windows 2000, and cannot get it to run. Whenever I start the server (the default domain), I get the following error message in a pop-up window labeled "Java Virtual Machine Launcher":

    "Could not find the main class. Program will exit."

    Has anyone else had this problem? Has anyone been successful, or found a work around?

    Threaded Messages (3)

  2. Never mind. I fixed it.[ Go to top ]

    There was a problem with my path:

    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;"C:\Program Files\Symantec\Norton Ghost 2003\"

    In particular, having quotes in my Windows path was interfering with the J2EE server's launcher logic, though the errors were very strange.
  3. Never mind. I fixed it.[ Go to top ]

    Two questions:
    * What is your CLASSPATH ?
    * Why the $JAVA_HOME/bin is not in the path ?

    David
  4. Never mind. I fixed it.[ Go to top ]

    I never put my Java home in my system path, and never set a classpath globally. I always set them locally in starter scripts (batch files, ant scripts). I run too many different versions of Java on my machine to specify these items globally.

    Anyway, the problem turned out to be that there was a quoted name in my system path. The starter batch files for the J2EE SDK also quote the entire system path, and the quotes inside and around the path were conflicting.

    When I removed the quotes from my system path, everything worked.

    None of this would be an issue if Windows disallowed spaces in paths (or Unix allowed them).