Discussions

General J2EE: websphere J2RE version

  1. websphere J2RE version (4 messages)

    I would like to know if it's possible or how to find out, what JVM i'm using with my websphere. I'm developping in WSAD 5.1.2 and when the websphere testserver is starting i get the following log at the console:

    Java version = J2RE 1.3.1 IBM Windows 32 build cn131-20030711a (JIT enabled: jitc), Java Compiler = jitc, Java VM name = Classic VM

    but when I check the jvm version at dosprompth :

    java -version I get:

    java version "1.4.2_06"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)
    Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)

    J2EE is version 1.3 but I as far as I know that doesn't really mather does it ? I would like to use the new functions added to the J2RE 1.4 version in my websphere

    Threaded Messages (4)

  2. websphere J2RE version[ Go to top ]

    Hi Joeri,

    You may have multiple versions of Java. "Java -version" is going to find the first java.exe in you path. Try "which java".

    I don't think it is so easy to change Java versions for WebSphere ...without changing versions of WebSphere.

    Mike
  3. WAS JRE Version[ Go to top ]

    The message we got from IBM was that you can not use any other JRE except that which is included. Unfortunately, not even WAS 6.0 uses 1.4.x
  4. was jre[ Go to top ]

    why are they not using 1.4.x with there new WAS ? any reason for this ?
  5. WSAD and WAS JVMs[ Go to top ]

    why are they not using 1.4.x with there new WAS ? any reason for this ?

    WSAD (Studio) is using a specific version of Eclipse, and it's default runtime version is currently 1.3.x. WAS 5.1.1 (the actual WebSphere Application Server), is using a 1.4.2 runtime from IBM. Even though WSAD itself is running on 1.3.x, you can specify almost any JVM to use for your projects witing WSAD, including the ones from Sun. However, if your target environment is WAS 5.1, you should probably specify the BASE_V51 runtime for your project.

    I hope this helps.

    Ken Coe
    Systems Analyst
    Blue Cross and Blue Shield of Alabama