migrate a struts application from jboss 4 to tomcat 5.0.28

Discussions

Web tier: servlets, JSP, Web frameworks: migrate a struts application from jboss 4 to tomcat 5.0.28

  1. Dear all,

    I have to migrate my application (using struts, no ejb) from jboss4.0.0 to tomcat 5.0.8.

    My application works fine in jboss 4.0.0 server (the tomcat version of jboss 4 is 5.0.28), I just change the connection settings and put my application to tomcat.

    Then, I found that my application can connection to db. but all the servlet (*.do) are not work. (it shows 404 error, servlet not found)

    I've placed the relative jar files within my application and the <tomcat>/common/lib. It still not work

    Please help

    Thanks a lot.

    Regards,

    Kin
  2. Did you put your war file (or exploded application directory) in the <TOMCAT>/webapps directory?
  3. Did you put your war file (or exploded application directory) in the <TOMCAT>/webapps directory?

    Yes, I did