Discussions

General J2EE: JDK 5.0 (1.5) and appservers

  1. JDK 5.0 (1.5) and appservers (9 messages)

    We want to use the cool new features of JDK 5.0, including generics and new libraries, with our webapp (servlet/JSP/Struts, no EJB). Of course, generics compile to old-style bytecode, but once we've made the shift, we won't want to ban our developers from using new libraries, and we prefer not to use a halfway solution of generics-with-1.4.

    But customers may be using older versions of appservers tha do not support JDK 5.0. Which appserver versions support JDK 5.0? Is there an article out there describing the how to make the shift to JDK 5.0 for webapps?

    Thanks,

    Joshua

    Threaded Messages (9)

  2. JDK 5.0 (1.5) and appservers[ Go to top ]

    Hi Joshua,

    If you only need a web container, then try Tomcat 5.5. It is built for JDK 5.
  3. Java 5 and appservers[ Go to top ]

    Thanks, yes, Tomcat 5.5 and WebLogic 9 (now in Beta) will support Java 5. But we have a number of customers who use older versions of WebLogic and WebSphere, and since these are conservative enterprises, they will not change easily. Any tips on how to move to Java 5 in this situation?
  4. Re: JDK 5.0 (1.5) and appservers[ Go to top ]

    Hi,

    the whole Sun Java System Application Server Suite from 8.1 (current version) supports JDK 1.4.2.x and JDK 5, from Platform Editon over Standard Edition to Enterprise Edition.

    Regards
    Klaus
  5. Re: JDK 5.0 (1.5) and appservers[ Go to top ]

    Thanks, so
       - WebLogic 9 (in Beta)
       - Tomcat 5.5
       - Sun Java System AS 8.1
     support Java 5.

    What about WebSphere? Is that moving to Java 5?

    And are there any tips on how we can move to Java 5 as developers yet support older appservers -- since enterprises are often reluctant to upgrade?
  6. Re: JDK 5.0 (1.5) and appservers[ Go to top ]

    If you want to move to Java 5 *and* take advantage of the new (non-backward compatible) features, you'd probably have to write two versions of your code :(
  7. Re: JDK 5.0 (1.5) and appservers[ Go to top ]

    You can also use Oracle's Application Server Containers for J2EE (OC4J) from http://otn.oracle.com/ejb3

    Rob
    http://www.robsite.org
  8. Re: JDK 5.0 (1.5) and appservers[ Go to top ]

    Another issue is that there is no jdbc driver for jdk1.5
    for Oracle 10g.
  9. JBoss ...[ Go to top ]

    You can use JBoss 3.2.6/3.2.7 or JBoss 4.0.x.

    Regards,
    Rafal
  10. Remeber .jsp[ Go to top ]

    If your jsp-files also are written using 1.5 syntax you might encounter problems, because e.g. Tomcat sometimes uses a different compiler than javac, and this compiler only supports 1.4 syntax. This can usually be configured, but it is not always easy and you have to remember to do it.

    Just tried to make 1.5 jsps work with JBoss-4.0.2 and it doesn't work - had to use old-style for-loops :(