putting utility jar file in j2ee server

Discussions

EJB programming & troubleshooting: putting utility jar file in j2ee server

  1. putting utility jar file in j2ee server (5 messages)

    I am using JBuilder 2005 with weblogic server 8.1 I am having a problem which is I have created some utility classes to use in the context of entity bean I have made a jar file of that classes and put it that jar file in \WEB-INF\lib folder after that I compile it it works fine at that time but whenever I tried to run it it give me the runtime exception ava.lang.NoClassDefFoundError erro .It happens when I tried to make a class object via new in my entiy bean
  2. If you specify the jar files location in the class path of the startweblogic file e.g. startWeblogic.cmd or startWeblogic.sh then the jar should be picked up. Alternativly you could drop the jar file into the BEA lib directory where it sholud be picked up by the default bea class path.
    Hope this helps
    Bass
  3. putting utility jar file in j2ee server[ Go to top ]

    This is what worked for me in WSAD for the exact same problem:

    1. Create another Java Project. Import utility.jar in there.
    2. In EAR, add this java project as "Project Utility Jar".
    3. In Web App project (WAR), add dependency to this App level jar.

    Hope it helps. I would most definitely like to know if there is any other/better way (which I am sure is, just haven't found that yet)

    P.I.
  4. Yep! That is exactly what I did...and I think it is kind of neat - all properties and related stuff neatly bundled together. Though would like to alternate packaging schemes,

    ~Regards
  5. ha I did came across yesterday. Open your config.xml remove application part. restart your appserver and deploy application again. That sucker would work.
  6. putting utility jar file in j2ee server[ Go to top ]

    ha I did came across yesterday. Open your config.xml remove application part. restart your appserver and deploy application again. That sucker would work.

    I didn't get it - how exactly to do this? config.xml - where is this file? I am using websphere.
    Thanks,
    P.I.