Weblogic and Struts

Discussions

Web tier: servlets, JSP, Web frameworks: Weblogic and Struts

  1. Weblogic and Struts (1 messages)

    Hi All,

    I want to deploy a struts based enterprise application( struts and ejb ) in weblogic server.Deployed the application but it is showing the following error on the server console.

    <Jul 4, 2005 4:24:31 PM GMT+05:30> <Error> <HTTP> <BEA-101216> <Servlet: "action" failed to preload on startup in Web application: "TbmsContextRoot".
    javax.servlet.ServletException: org/apache/commons/digester/Digester
            at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:919)
            at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:883)
            at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:822)
            at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:3333)
            at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:3278)
            at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:3259)
            at weblogic.servlet.internal.WebAppServletContext.setStarted(WebAppServletContext.java:5949)
            at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:862)
            at weblogic.j2ee.J2EEApplicationContainer.start(J2EEApplicationContainer.java:2127)
            at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:2168)
            at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:2115)
            at weblogic.management.deploy.slave.SlaveDeployer$Application.setActivation(SlaveDeployer.java:3082)
            at weblogic.management.deploy.slave.SlaveDeployer.setActivationStateForAllApplications(SlaveDeployer.java:1751)
            at weblogic.management.deploy.slave.SlaveDeployer.resume(SlaveDeployer.java:359)
            at weblogic.management.deploy.DeploymentManagerServerLifeCycleImpl.resume(DeploymentManagerServerLifeCycleImpl.java:229)
            at weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131)
            at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:966)
            at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:361)
            at weblogic.Server.main(Server.java:32)
     
    Seems the application is not loading the jar files provided in WEB-INF/lib directory.Do I need to specific the jar details in some other place in weblogic server.


    Can anyone help me with this issue ? Please respond. Thanx.

    Regards,
    vinu.
  2. Weblogic and Struts[ Go to top ]

    Hi All,I want to deploy a struts based enterprise application( struts and ejb ) in weblogic server.Deployed the application but it is showing the following error on the server console.<Jul 4, 2005 4:24:31 PM GMT+05:30> <Error> <HTTP> <BEA-101216> <Servlet: "action" failed to preload on startup in Web application: "TbmsContextRoot".javax.servlet.ServletException: org/apache/commons/digester/Digester&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:919)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:883)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:822)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:3333)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:3278)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:3259)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.WebAppServletContext.setStarted(WebAppServletContext.java:5949)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:862)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.j2ee.J2EEApplicationContainer.start(J2EEApplicationContainer.java:2127)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:2168)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:2115)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.management.deploy.slave.SlaveDeployer$Application.setActivation(SlaveDeployer.java:3082)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.management.deploy.slave.SlaveDeployer.setActivationStateForAllApplications(SlaveDeployer.java:1751)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.management.deploy.slave.SlaveDeployer.resume(SlaveDeployer.java:359)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.management.deploy.DeploymentManagerServerLifeCycleImpl.resume(DeploymentManagerServerLifeCycleImpl.java:229)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:966)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:361)&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;at weblogic.Server.main(Server.java:32)&nbsp;Seems the application is not loading the jar files provided in WEB-INF/lib directory.Do I need to specific the jar details in some other place in weblogic server.Can anyone help me with this issue ? Please respond. Thanx.Regards,vinu.

    Hi Vinu, U should go to download this link :
    http://jakarta.apache.org/commons/digester/

    and download the commons-digester.jar , put it in your WEB-INF/lib, and then try to restart your app.server

    good luck.