Discussions

News: TIBCO General Interface Professional Edition v3.2 released

  1. Version 3.2 (Beta 2) of TIBCO General Interface Professional Edition, an Ajax toolkit for building and deploying Rich Internet Applications (RIA), is now available through an open source BSD license option. This latest version of General Interface includes support for Firefox 1.5. The beta also provides:
    • SVG charting for Firefox 1.5
    • New Matrix control supporting
    • Lists, Grids, Trees, Tree-Grids and Tree-Lists
    • New editable cell types including simplified means for making your own
    • Multiple data pagination modes for handling large data set displays
    • More components, including color and time pickers
    • Faster init times
    • Enhancements to the visual authoring tools
    Following the beta period, TIBCO, a member of the OpenAjax Alliance, will provide unobfuscated, uncompressed source for the release. What do you think of the new features in this latest Beta?

    Threaded Messages (8)

  2. really...GOOD[ Go to top ]

    i tried it and i can claim that i find it amazing finally,i found something better than dojo as it freeze my browser actually it come with its own GUI builder and editor but it will be a pleasure to develop in IDEA as it has a superb javascript support
  3. Finally Firefox Supported[ Go to top ]

    Hard to believe it took so long to support FF.
  4. lots in there[ Go to top ]

    Took a while yep. Most of it was waiting for Firefox 1.5 to become generally available and the fact that there's just so much in this product (over 100 out of the box components, plus the full visual tools and debugging suite). FX 1.5 added support for SVG enabling the GI team to port the VML charts we had in IE to FX1.5. Best of all FX is faster overall. I can say our developers love FX. kevin hakman @ tibco dot com
  5. It is strange, but Preview links on site still cannot work with FF. I am getting 'IE 6+ required' popups. Dmitry Coldbeans
  6. It is strange, but Preview links on site still cannot work with FF. I am getting 'IE 6+ required' popups.
    FYI, you need to pick "TIBCO General Interface Version 3.2 (Beta)" in their "Filter by Product" dropdown to see the samples that run in Firefox. If you hit the back button on that page, it will still say Version 3.2 (Beta), but you will actually be looking at the 3.1 examples that run against IE6/Windows only. In other enterprise AJAX news (shameless on-topic plug :), the SmartClient AJAX GUI system version 5.5 was released this week on www.SmartClient.com. If you're looking for a mature AJAX platform for business web applications, check it out! Over 200 live feature demos are now running without any registration or download. Cheers- Jeff Dill www.GetAjax.com
  7. re SmartClient[ Go to top ]

    expensive but very nice looking. excellent online samples.
  8. Is there any demonstration of the technology ? Cyril
  9. Slowjax[ Go to top ]

    I've tried the online demo and it appears to be so slow. Isn'it?