Discussions

EJB programming & troubleshooting: Unable to use EJB3 + JPA with Weblogic Workshop 10.3

  1. I downloaded Oracle Weblogic 10.3. I was expecting that the new Workshop would have straight forward support for JPA and EJB 3. It has support for both, but not together!! I can add JPA facet ONLY to a web project and not to EJB project!! That is rather strange!! My web tier calls the session beans which in turn must use JPA. Somebody from BEA / Oracle can pls throw some light as to is it a bug or a (missing) feature? Pradeep LN www.pratian.com
  2. Pradeep, Hi, Oracle WebLogic Server 10.3 is working with EclipseLink JPA 1.0 / EJB 3.0 inside the Eclipse 3.4 IDE, you can also add the design time JPA facet for DALI to both the Web and EJB projects. The following quick start tutorial on configuring a small EAR application that uses a servlet client to access a JPA 1.0 container managed entityManager on a EJB 3.0 stateless session bean is demonstrated at the following URL. http://wiki.eclipse.org/EclipseLink/Examples/JPA/WebLogic_Web_Tutorial Thank you for the info on Workshop, I have not tried Workshop with WebLogic 10.3 yet with JPA and will post results for this on our examples page as I get them to... http://wiki.eclipse.org/EclipseLink/Examples/JPA /michael att eclipselink.org