Discussions

EJB programming & troubleshooting: ca't create connection pool in weblogic5.1

  1. hai to everybody,
    if i tried to create a connecion pool in
    weblogic5.1.the following error occured(if i use jts driver)
    java.sql.SQLException: User SCOTT is unknown in realm weblogic.security.acl.internal.WLPropertyRealm@c01dbb7c
            at weblogic.jdbcbase.jts.Driver.connect(Driver.java:121)
            at weblogic.jdbc.common.internal.ConnectionEnvFactory.makeConnection(ConnectionEnvFactory.java:149)
            at weblogic.jdbc.common.internal.ConnectionEnvFactory.createResource(ConnectionEnvFactory.java:109)
            at weblogic.common.internal.ResourceAllocator.makeResources(ResourceAllocator.java, Compiled Code)
            at weblogic.common.internal.ResourceAllocator.<init>(ResourceAllocator.java, Compiled Code)
            at weblogic.jdbc.common.internal.ConnectionPool.startup(ConnectionPool.java:330)
            at weblogic.jdbc.common.internal.JdbcInfo.initPools(JdbcInfo.java, Compiled Code)
            at weblogic.jdbc.common.internal.JdbcInfo.startup(JdbcInfo.java:200)
            at weblogic.jdbc.common.internal.JdbcStartup.main(JdbcStartup.java:11)
            at java.lang.reflect.Method.invoke(Native Method)
            at weblogic.t3.srvr.StartupThread.runMain(StartupThread.java:219)
            at weblogic.t3.srvr.StartupThread.doWork(StartupThread.java, Compiled Code)
            at weblogic.t3.srvr.PropertyExecuteThread.run(PropertyExecuteThread.java:62)
    Thu Apr 22 16:45:34 GMT+05:30 1999:<I> <JDBC Pool> Sleeping in createResource()
    Thu Apr 22 16:45:35 GMT+05:30 1999:<E> <JDBC Pool> Failed to create connection pool "oraclePool"wing error occured


  2. It looks like your Connection pool is not setup correctly.

    Could you post the connection pool entry from the weblogic.properties file. Also the entries for :-

    weblogic.allow.reserve.weblogic.jdbc.connectionPool.oraclePool=
    weblogic.jdbc.TXDataSource.weblogic.jdbc.jts.oraclePool=

    Cheers,
    Rick
  3. You need to add something like...

    weblogic.password.SCOTT=<password you will pass to JDBC URL>

    in weblogic.properties.

    Looks like you are setting the pool to be accessible by user SCOTT but that you never told the server about user SCOTT.

    Chz

    Tony
  4. Try changing your connection properties from weblogic.properties file.
  5. Try changing your connection properties from weblogic.properties file.