Discussions

EJB programming & troubleshooting: Orion & VAJ

  1. Orion & VAJ (1 messages)

    Does anyone know how to run Orion within VisualAge for Java?

    Orion exits with this error message:

    Servlet API version 2.2 or greater required.
    orion.jar contains the Servlet 2.2 API but a
    case of library shadowing has been detected.
    Remove any potential old/offending libraries
    from the classpath and retry.
    The offending library resides at: valoader:/C:/Program Files/IBM/VisualAge for Java/ide/project_resources/Orion/

    However, none of the jars in that directory contain the javax.servlet package. It's only in the Orion project.

    Threaded Messages (1)

  2. Orion & VAJ[ Go to top ]

    the error probably arises because Visual Age itself (are you using the professional or enterprise edition? if so then the assumption is correct) already contains the libraries for servlets/jsp. Remove one of the duplicate libraries from the projects classpath.

    Cheers,

    Steven Sagaert