problem in lookup

Discussions

EJB programming & troubleshooting: problem in lookup

  1. problem in lookup (1 messages)

    hi, I have deployed a sample EJb(Helloworld) on Oracle8i(8.1.6) database and am enable to run it thorough the client. The example is provided by Oracle with their software. The problem I am facing is the Lookup failure and msg I am getting is following:=>C:\helloworld>java Client sess_iiop://tooshar:2481:FIRST /test/Tushar scott tiger
    Inside main
    Before Lookup
    ::: org.omg.CORBA.OBJECT_NOT_EXIST
    org.omg.CORBA.OBJECT_NOT_EXIST[completed=NO]
            at com.visigenic.vbroker.orb.SE.read(SE.java:36)
            at com.visigenic.vbroker.orb.GiopStubDelegate.invoke(GiopStubDelegate.java:579)
            at com.visigenic.vbroker.orb.GiopStubDelegate.invoke(GiopStubDelegate.java:479)
            at com.inprise.vbroker.CORBA.portable.ObjectImpl._invoke(ObjectImpl.java:60)
            at org.omg.CORBA._st_InitialReferences.get(_st_InitialReferences.java:32)
            at oracle.aurora.jndi.sess_iiop.SessionCtx.initialContext(SessionCtx.java:534)
            at oracle.aurora.jndi.sess_iiop.SessionCtx.<init>(SessionCtx.java:35)
            at oracle.aurora.jndi.sess_iiop.ServiceCtx.createSession(ServiceCtx.java:128)
            at oracle.aurora.jndi.sess_iiop.ServiceCtx.login(ServiceCtx.java:306)
            at oracle.aurora.jndi.sess_iiop.ServiceCtx.defaultSession(ServiceCtx.java:183)
            at oracle.aurora.jndi.sess_iiop.ServiceCtx.lookup(ServiceCtx.java:330)
            at oracle.aurora.jndi.sess_iiop.sess_iiopURLContext.lookup(sess_iiopURLContext.java:232)
            at oracle.aurora.jndi.sess_iiop.sess_iiopURLContext.lookup(sess_iiopURLContext.java:218)
            at javax.naming.InitialContext.lookup(InitialContext.java:349)
            at Client.main(Client.java:33)

    can anybody please suggest something:: my mail id is tusharvg at newgen dot co.in

    Threaded Messages (1)

  2. problem in lookup[ Go to top ]

    The exception makes it obvious that the object for which you are performing a lookup hasnt been deployed on the server OR it has been deployed and you are using the wrong name in the lookup.
    -RAJ