Discussions

XML & Web services: Startweblogic.cmd

  1. Startweblogic.cmd (2 messages)

    I am getting the following error message when I use the startweblogic command.

    Does anybody know what I need to change to make it right?

    Exception in thread "main"
    java.security.AccessControlException: access denied (
    java.lang.RuntimePermission createSecurityManager)
            at java.security.AccessControlContext.checkPermission(AccessControlContext.java:272)
            at java.security.AccessController.checkPermission(AccessController.java:399)
            at java.lang.SecurityManager.checkPermission(SecurityManager.java:545)
            at java.lang.SecurityManager.<init>(SecurityManager.java:301)
            at weblogic.boot.ServerSecurityManager.<init>(ServerSecurityManager.java:11)
            at weblogic.Server.main(Server.java:59)
            at weblogic.Server.main(Server.java:55)

    Threaded Messages (2)

  2. Startweblogic.cmd[ Go to top ]

    One thing to try is to make sure that the Security tag in config.xml has GuestDisabled="false"
  3. Startweblogic.cmd[ Go to top ]

    Open weblogic.properties and whereever u see that there is access been given change it to everyone,this is one of the places u will find it


    # SECURITY-RELATED PROPERTIES FOR WORKSPACES
    # ------------------------------------------------
    # For backward compatibility, the following entries disable Access
    # Control on Workspaces
    weblogic.allow.read.weblogic.workspace=everyone
    weblogic.allow.write.weblogic.workspace=everyone


    mahesh