problem deploying a web application to oc4j in Unix


Web tier: servlets, JSP, Web frameworks: problem deploying a web application to oc4j in Unix

  1. Hi! I would like to ask for someone's help on a problem I encountered while accessing a web app deployed to oc4j in Unix. Before deploying the application in Unix, I tried it on a Windows2000 server and it worked fine. I copied the same files (classes, jsps, js, css) to the Unix server and modified the same xml files (data-sources, global-web-application, http-web-site, server). I could access index.jsp of my application but I get a HTTP 404 error on the other pages. Could someone share some insights on this and if you have experienced the same problem, kindly post your suggestions/solutions.

    Thanks a lot,
  2. hi,

    Best place to start debugging the problem is to look for the log
    and see if there are any exceptions been relevant to directory
    path patterns, file not found, resource not found etc.,

    Further, You may have to look at the adminstrator's and deployment guide
    for the guidelines (deployment).

    Bhagvan K
  3. Hi Bhagvan,

    Thanks for your reply. I'll check the resources you posted.

    Many thanks,