My name is Roberto and I'm working with WebSphere Application Server in linux - Red Hat, with kde 3.0.

I'm trying to install a new application using a shared library, but the library is not beeing used by any other application yet.

I've created the shared library with all the .jar's in the classpath, and I'm using a variable in their path. This is my shared library classpath:


I've checked ${MY_VARIABLE} path and it's ok. The shared library has been created in the same node as the application, so it is supposed to be seen by the application.

The problem is that when I install the application deploying the EJB's, it happens an error saying that my classpath is incomplete and that my .jar's couldnt be found.

I've looked ate the SystemOut log and what happens is that when the EJB's start beeing compilled, errors happen successively from the start. Its the same error than when I leave my classpath empty and try deploying the EJB. I did it just to comprovate my conclusion that my classpath is not been seen or used, or reached.

I have also tried installing the application without deploying the EJB's and latter setting the shared library in the "Enterprise Application", but the same happened.

I've already seen the IBM helps and manualls, but they didnt help.

That's the problem, if you can help me with any tips I will be very thankfull.