EJB design: UnsatisfiedinkError

  1. UnsatisfiedinkError (4 messages)

    My ejb is roperly deployed and when my client tries to lookup the ejb server component I find this error.
    ERROR! Shared library ioser12 could not be found.
    Exception in thread "main" java.lang.UnsatisfiedLinkError: specialLoadClass
            at com.sun.corba.ee.internal.util.JDKClassLoader.loadClass(JDKC
            at com.sun.corba.ee.internal.util.JDKBridge.loadClassM(JDKBridg
            at com.sun.corba.ee.internal.util.JDKBridge.loadClass(JDKBridge
            at javax.rmi.CORBA.Util.loadClass(Util.java:216)
            at javax.rmi.CORBA.Util.createDelegateIfSpecified(Util.java:307
            at javax.rmi.CORBA.Util.<clinit>(Util.java:55)
            at javax.rmi.PortableRemoteObject.createDelegateIfSpecified(Por
            at javax.rmi.PortableRemoteObject.<clinit>(PortableRemoteObject
            at Client.lookupHome(Client.java:146)
            at Client.<init>(Client.java:42)
            at Client.main(Client.java:80)
    If any one has encountered it please let me know at the earliest.

    Thanks in advance.


    Threaded Messages (4)

  2. UnsatisfiedinkError[ Go to top ]

    I suppose you are using Websphere as your application server, I've been experiencing the same problem too. I think it has to do with Websphere implementation of IIOP, its not exactly 100% J2EE compliant and there are some specific classes you have to use in creating the initial context. If you use Visual Age for your development, it tends to resolve the problem.
  3. UnsatisfiedinkError[ Go to top ]

    You may get this type of
    error with other application servers also..

    Most of the time you would use the vendors
    (eg Iona, Visigenic ) client ORB rather than
    Suns ORB ...

    You can use the right ORB
    by passing in environment parameter during
    the startup of the server..
    (eg with Weblogic you may pass :
    -Dorg.omg.CORBA.ORBClass=IE.Iona.OrbixWeb.CORBA.ORB -Dorg.omg.CORBA.ORBSingletonClass=IE.Iona.OrbixWeb.CORBA.singletonORB )
  4. message to chijioke[ Go to top ]

    Hi Chijioke,

    It's been a while.Don't know if you remember. we met in London at Borders Bookshop.Last I heard was you were going off to work at Microsoft.

    Have you been in touch with Remski (Remi Abudu).

    Please give me a shout at olajideadesanya at hotmail dot com


  5. UnsatisfiedinkError[ Go to top ]

    I am running jdk1.2.2, j2sdkee1.2.1, jboss 2 in linux redhat 6.2. I tried to access an EJB from jboss and got the same error. To resolve this error, I make a copy of the libioser12.so from J2EE_HOME/nativelib to JAVA_HOME/jre/lib/i386. I am not sure why but when I execute java, java was looking for the shared lib, libioser12.so, in the jre lib path. I hope this will help. Obviously from the error message, the library can be determined by java. Therefore, I think if you can put the library in the proper directory where java loads all the shared lib. You will solve your problem.