Servlet: "action" failed to preload due to servlet exception wit


General J2EE: Servlet: "action" failed to preload due to servlet exception wit

  1. Hello,

    I have tried struts application excecuting in Weblogic in which i created my own Domain, Whenever i start the server i m encountering the following error before deplyment. This is becoz of the ActionServlet may be.

    <Error> <HTTP> <BEA-101216> <Servlet: "action" failed to preload on startup
    in Web application: "XYZ".javax.servlet.ServletException:org/apache/commons/digester/RuleSet at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm at
    weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub at
    weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI at
    weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppS at
    weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebApp at
    weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAp at
    weblogic.servlet.internal.WebAppServletContext.setStarted(WebAppServl at
    weblogic.servlet.internal.WebAppModule.start( at
    weblogic.j2ee.J2EEApplicationContainer.start(J2EEApplicationContainer .java:2022) at
    weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContai at$ComponentActivateTask.
    activateContainer( at$ActivateTask.doCommit( at$Task.commit(SlaveDeplo at$Task.checkAutoCommit(S at$Task.prepare(SlaveDepl at$ActivateTask.prepare(S at at at at
    weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHan at
    weblogic.kernel.ExecuteThread.execute( at > <Mar 21, 2006 5:18:59 PM IST> <Warning>
    <HTTP> <BEA-101248> <[Application: 'C:\b ea8.1\user_projects\domains\mydomain\applications',
    Module: 'servetexample']: De ployment descriptor "web.xml" is malformed. Check against the DTD:
    org.xml.sax.S AXParseException: cvc-elt.1: Cannot find the declaration of element 'web-app'. ( line
    2, column 10).> <Mar 21, 2006 5:19:04 PM IST> <Warning> <HTTP> <BEA-101248> <[null]: Deployment
    descriptor "web.xml" is malformed. Check against the DTD: org.xml.sax.SAXParseEx ception: cvc-
    elt.1: Cannot find the declaration of element 'web-app'. (line 2, c olumn 10).>

    Struts-config.xml, web.xml are perfectly alright.

    Even i am able to execute same application In TOMCAT sucessfully.
    Plz help me so that i can work it out with WEBLOGIC. I guess The RuleSet inetface has some problem.

    Do reply me ASAP.
  2. Prasad,

    The digester doesn't like the web.xml file, so I'd be interested to know upon which facts you based your decision that it is 'perfectly alright'.

    Maybe you could post the web.xml file, so that we can determine where the problem lies?

  3. Thanks Bob for ur inputs,

    After alot of R&D i found the solution for this.It cannot be called as solution becoz i uninstalled the WLS8.1.2 & reinstalled it. Afetr that i deployed the same application.. and surprizingly it worked..

    I astonised, really i tried to dig in it but i didn't find any reason for that...

    Whats ur words on it.

  4. I hate it when this kind of thing happens, because you never really know what went wrong so you're not sure if it'll come back at some point.

    In the end though, I wouldn't lose any sleep over it - just get one with the next thing on your list.