Need HELP - problem using JBoss in Eclipse 3.2 IDE


Web tier: servlets, JSP, Web frameworks: Need HELP - problem using JBoss in Eclipse 3.2 IDE

  1. Our dev team just installed Eclipse 3.2 and JBoss 4.0.5.GA on our local Window XP machines. When selecting the option "run on server" a JSP page from within the Eclipse 3.2 IDE I am getting an error. It appears(?) that the issue is that Eclipse will rebuild and redeploy the EAR to JBoss while at the same time opening up IE and trying to load the JSP. JBoss eventually will see the new EAR and it has to go through a process of unloading the current EAR from memory and then reloading the new EAR. The error I see is happening when JBoss unloads the current EAR from memory as far as I can tell. Any help or direction would be greatly appreciated. We're not sure whether the problem exists in Eclipse or JBoss. Eclipse says that it is not their problem so I'm just trying to get additional input. Here is the error that I am getting: HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception java.lang.NullPointerException java.lang.ClassLoader.loadClass(Unknown Source) java.lang.ClassLoader.loadClass(Unknown Source) java.lang.ClassLoader.loadClassInternal(Unknown Source) org.acegisecurity.ui.ntlm.NtlmProcessingFilter.onPreAuthentication( org.acegisecurity.ui.AbstractProcessingFilter.doFilter( org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter( org.acegisecurity.ui.ExceptionTranslationFilter.doFilter( org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter( org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter( org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter( org.acegisecurity.util.FilterChainProxy.doFilter( org.acegisecurity.util.FilterToBeanProxy.doFilter( org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter( note The full stack trace of the root cause is available in the Apache Tomcat/5.5.20 logs.
  2. JBOSS IDE[ Go to top ]

    Hi, u can try using Eclipse JBOSS IDE available at JBOSS's official website...
  3. Re: JBOSS IDE[ Go to top ]

    Actually we were trying to NOT to have use JBoss' version of Eclipse and wanted to stay with what was "standard" if that makes sense. We were only trying to use JBoss as our application server. Thanks anyway.
    Hi, u can try using Eclipse JBOSS IDE available at JBOSS's official website...
  4. Have you tried switching off the automatic build? I would be inclined to try turning off this and any other auto options that you might have set. Then try doing the build and deploy manually before starting the server and running your jsp
  5. David, Thanks for the reply. Unfortunately I am still getting the same error. Any additional thoughts would be appreciated. Regards.
  6. Melinda, I'm afraid I don't use jboss, so I have no other ideas to suggest. I assume you have tried the Eclipse and, perhaps more pertinently, the jboss fora? Good Luck