Deploying JSPs in Weblogic 5.1


Web tier: servlets, JSP, Web frameworks: Deploying JSPs in Weblogic 5.1

  1. Deploying JSPs in Weblogic 5.1 (8 messages)

    Hi All,

    I am trying to deploy a JSP by creating .war file(not copying the jsp to doc-root). The deployment went throught fine but when I call the JSP through a form, the browser shows "ERROR 500" and the weblogic console is showing the following error at the time of compiling the generated .java file.

    Tue Feb 27 14:20:04 EST 2001:<I> <ServletContext-loginx> Generated java file: C:
    Tue Feb 27 14:20:04 EST 2001:<E> <ServletContext-loginx> Compilation of C:\users
    \Srini\login-j2ee\login\_tmp_war\jsp_servlet\ failed:
    ception: CreateProcess: javac -classpath C:\weblogic\myserver\serverclasses;C:\w
    ogin\_tmp_war -d C:\users\Srini\login-j2ee\login\_tmp_war C:\users\Srini\login-j
    2ee\login\_tmp_war\jsp_servlet\ error=2
            at java.lang.Win32Process.create(Native Method)
            at java.lang.Win32Process.<init>(
            at java.lang.Runtime.execInternal(Native Method)
            at java.lang.Runtime.exec(
            at java.lang.Runtime.exec(
            at weblogic.utils.Executable.exec(, Compiled Code)
            at weblogic.utils.Executable.exec(
            at weblogic.utils.compiler.CompilerInvoker.compileMaybeExit(CompilerInvo, Compiled Code)
            at weblogic.utils.compiler.CompilerInvoker.compile(
            at weblogic.servlet.jsp.JspStub.compilePage(, Compiled Code)

            at weblogic.servlet.jsp.JspStub.prepareServlet(
            at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
            at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
            at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
            at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
            at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
            at weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
            at weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
            at weblogic.socket.MuxableSocketHTTP.execute(

            at, Compiled Code)

    The JSP code is

    Login Check
    <%@ page errorPage="../error.jsp" %>
    userid <%= request.getParameter("userId") %> <br>
    password <%= request.getParameter("password") %> <br>
    <jsp:useBean id="sessionuser" class="Srini.User" scope="session" />
    <% if(request.getParameter("userId")==null || request.getParameter("password")==null || ((String) request.getParameter("userId")).equals("") || ((String) request.getParameter("password")).equals(""))
    <jsp:getProperty name="sessionuser" property="userId" />
    <jsp:setProperty name="sessionuser" property="dSName" param="MSAccess" />
    <jsp:setProperty name="sessionuser" property="userId" param="userId" />
    <jsp:setProperty name="sessionuser" property="password" param="password" />

    Login successfull

    FYI : the sample cookie web application is working fine by deploying and the above shown jsp works fine without deploying.


    Threaded Messages (8)

  2. I don't think you have properly specified your JSP compiler.
    See weblogic.jsp.compileCommand in for the exact syntax.


  3. Evan,

    I have given it correctly. The properties file itself has a sample commented line for this property.

    Tried again and is giving the same error.

  4. Please see the URL I posted. If I read it correctly it is not sufficient to specify the JSP compiler in It must be in web.xml for .war files.

    This seems like a huge deployment issue but it's apparently the way it is supposed to be.

  5. Evan,

    Tried with the following web.xml. Still having the same problem.

    <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 1.2//EN" "">



  6. Your slashes are messed up:


    First, I assume you need a slash after "c:" Except .cmd files you should always use forward slashes when you specify file paths in weblogic. Try using:


  7. Evan,

    Still having the same problem.

    I refered weblogic news group. I found some guy posting the same problem and no one has given a solution for that.

  8. What newsgroup? I did not see it in weblogic.developer.interest.jsp.
    Are you able to deploy the webapp example? Try opening error.jsp.

    It works fine for me but it seems to use %JAVA_HOME%/bin/javac as its compiler. It uses different settings from and web.xml does not contain any jsp stuff. Is it possible you are using a "jre" instead of a "java" to launch? If so try launching with a directory containing "bin/javac" as %JAVA_HOME%.

  9. Evan,

    I went to the posting through the url and gave "Compilation problem in deploying JSPs in 5.1" in the question and pressed go. In the list the second in the news group listing with subject "Subject: Compilation failure when using WAR: call to ServletContextImpl.isResourceStale in generated .java doesn't match call in WL class file".

    That person has told he got a compilation error while compiling manually but I am not getting that. It compiles fine while doing manually.

    Even the webapp is not working for me.