iPlanet Vs Weblogic --- design issue


EJB design: iPlanet Vs Weblogic --- design issue

  1. iPlanet Vs Weblogic --- design issue (2 messages)

    Hi all

    I met a strange situation while developing my project.I used iPlanet 6.0 for deploying my beans.It all goes well.Even it is functional on net.

    Later i tried same application on weblogic 5.1. I found

    a)for weblogic primary key class must implement hash() and equals function.But primary key class without these functions run well in iPlanet.
    (My pk class running on net doesn't have these functions.But while deploying in weblogic it give error on pk class which i overcome by writing reqd. functions)

    b)When i run application on weblogic it gives some strange error.
    myEjbObject o bi=home.findByAll();

    above line runs perfectly on iPlanet.But in weblogic it is giving Dr.Watson's error.
    wlserver.exe Exception:access violation(oxc0000005)Address,ox77f6ce0c

    So is it that iplanet has not follow all rules of specifications or something else? (as in case of primary class)

    Why the behaviour of these two servers are so different?Iam aware that container's are vendor specific, but at the same time EJB's deployed (and run) in one container should also deploy and run in other container . So why this sought of behaviour?

  2. a) From EJB 1.1 spec:
    9.2.9 Entity bean&#8217;s primary key class
    The Bean Provider must specify a primary key class in the deployment descriptor.
    The primary key type must be a legal Value Type in RMI-IIOP.
    The class must provide suitable implementation of the hashCode() and equals(Object
    other) methods to simplify the management of the primary keys by client code.

    b) "Access violation" error sometimes happens when using Oracle OCI driver. Try to use Oracle thin driver instead.

    Also I recommend you to run weblogic using startweblogic.cmd script, not by using wlserver.exe
  3. hi

    a)Yes iam aware of this fact about primary key class.I wanna know if iplanet doesn't follow specification strickly.

    b)I am using JDBC/ODBC bridge for database connectivity.Iam using MSSQL server on other machine.
    Database connectivity is no problem .I got problem in accessing the bean functions via

    myEjbObject o bi=home.findByAll();

    I also used startweblogic.cmd script instead but my problem remains as such.I got following error:
    java.exe Exception:access violation(oxc0000005)Address,ox77f6ce0c

    Could you help meout in this situation.

    Stanislav , could u just explain the difference in using wlserver.exe and startserver.cmd script in starting server.