Weblogic: can't understand the path settings on windows 98


EJB programming & troubleshooting: Weblogic: can't understand the path settings on windows 98

  1. I downloaded an eval copy of weblogic and am trying to use it on windows 98. Having problems understanding how all the different path and classpaths work. I have tried many different configurations of the classpaths in my autoexec.bat file, but I still get a class not found exception when I try to run the examples beans. Can anyone explain to me exactly how I set these up to run the stateless session bean example?
    My path and classpath settings are as follows:

    SET CLASSPATH=.;C:\jdk1.3\lib;C:\oracle\ora81\bin;C:\oracle\ora81\jdbc\lib\classes12.zip;c:\j2sdkee1.2.1\bin;C:\jdk1.3\bin;C:\j2sdkee1.2.1\libc:\weblogic\classes\boot;c:\weblogic\lib\weblogicaux;c:\weblogic\myserver\serverclasses;%CLASSPATH%

    Java home in my setEnv.cmd is set to jdk1.3/lib/tools.jar

    I am hoping to figure this out so that I can run at least one bean before my 30 day license expires. I have jdk1.3 if that makes any difference.
    Would appreciate any guidance
  2. Well here are a couple of things I noticed right away:

    * You have a colon in your classpath instead of a semicolon
    * You did not put weblogicaux.jar or weblogicaux.zip (depending on your version of weblogic). Rather you just put 'weblogicaux'.

    BEA has some superb docs on how to set the classpath on their web site. I would check out those before consulting this forum.
  3. Weblogic: Reply to Mr. Roman[ Go to top ]

    Thanks for the tip. I am enjoying your book and might even buy it once I get this classpath situation under control. g.
    I took all of those weblogic classes out of my autoexec.bat file and am now trying to use scripts to set the classpaths on the command line. It seems that the files which end in .jar are not being found because the system is replacing the . with a backslash. for example if I type in
    I get a message saying that class cweblogic\lib\weblogicaux/jar not found.
    Same thing happens when I type -cp c:\jdk1.3\lib\tools.jar
    it comes back saying can't find c:\jdk1/3\lib\tools/jar.
    Is it me or the system?
  4. Please let me know where can I get the eval copy of Weblogic for win98 platform.
    I am not able to find it on BEA site.

  5. Hello
    I got the same error. I got it set by giving some more space in front of the path which shows the error.
    But then I got a new problem stating
    exception in thread main noclassdeffound d:\weblogic\license

    the path i set was
    set path=c:\jdk1.2.2\bin;d:\weblogic\bin;%path%
    java -ms64m -mx64m -classpath d:\weblogic\classes\boot

    -Dweblogic.class.path=d:\weblogic\classes; d:\weblogic\license;

    d:\weblogic\lib\weblogicaux.jar; d:\weblogic\myserver\serverclasses weblogic.Server

    can anybody help me to rectify this error.
    thanks for any help.