accessing webservice: https//


XML & Web services: accessing webservice: https//

  1. accessing webservice: https// (2 messages)

    I have one WSDL, which if i try to open in IE, asks for the nek/pwd...(it starts with https) i can open the wsdl after entering those details. i need to acces that web service .. i went with jax-rpc clinet approach. i have generated clinet jar-classes (by saving that wsdl locally and using clinet-gen utility) but i am failing to access that webservice.. i tried with diff ways to deal with secured webservice.. one first tried was: websvc.SearchService_Impl tempService = new websvc.SearchService_Impl(); websvc.Search_Stub stub = (websvc.Search_Stub ) tempService.getSearch(); stub._setProperty(Stub.USERNAME_PROPERTY, "user"); stub._setProperty(Stub.PASSWORD_PROPERTY, "pwd"); but it failed... second approach i tried was : System.setProperty( "javax.xml.rpc.ServiceFactory", "weblogic.webservice.core.rpc.ServiceFactoryImpl"); Call call = service.createCall(); call.setProperty(Call.USERNAME_PROPERTY, "user"); call.setProperty(Call.PASSWORD_PROPERTY, "pwd"); but both were failed... the same service can be access from .net framework using those credentials. i tried to google on this, and found many different articles/ ways / theories which confused me more..somthing like need security certificate etc.. keeping the fact that i don't have strong concepts on secured web services, can anyone suggest me how can i access the webservice ? also on thing i need to confirm; the authentication window i get; is it a network authentication or its a webservice authntication ? can anybody help me in solving this jargon thnks Abhijit.
  2. i have accesses some test webservices from using both approaches i wrote about and they have worked... also url is just symbolic, being client's production webservice, I am not able to reveal its true url and pwd... Thanks, Abhijit
  3. WSDL accessing https server[ Go to top ]

    Hi Abhijit, If you have solved this problem could you please help me to solve the same issue. I am also facing same problem, please guide