Problem in passing HttpResponse as a parameter


EJB programming & troubleshooting: Problem in passing HttpResponse as a parameter

  1. This is the problem i am getting only with weblogic6.0 not weblogic5.1

    when i pass HttpResponse object as a parameter to a business
    method of a bean, its is giving me a exception
    Its telling that the response object is not serialized
    so UnmarshalledException is coming

    when i deploy and run the bean in weblogic5.1 no problem is coming.... but with weblogic6.0 the Exception is coming

    can anyone help me out..

  2. It sounds like someone made HttpServletResponse a non serializable object when it used to be serializable.

    Wouldn't make a lot of sense, have you checked the BEA site for the list of bugs with 6.0 at all?


  3. I am getting the same error in moving from Weblogic 5.0 to 6.0. The Response object is not serializable, and probably should not have worked in 5.0, but does for some reason. If anyone has any info on this, please post it.