Client Jar Problem (Weblogic 5.1)


EJB programming & troubleshooting: Client Jar Problem (Weblogic 5.1)

  1. Client Jar Problem (Weblogic 5.1) (1 messages)

    Hello all,
    I have deployed my ejb's on one weblogic server(5.1). I have a client (servlets) running on another weblogic (5.1)server. The client machine has a jar which contains the Home and the Remote Interfaces of the beans that are deployed on the main server hosting the ejb's.
    However, I get the following exception when i try to access the beans on the server from the client.

    weblogic.rmi.UnmarshalException: Unmarshalling return
     - with nested exception:
    [java.lang.ClassNotFoundException: class com.opus.epg.useraccess.AdminSystemBeanHomeImpl_ServiceStub previously not found]
     at weblogic.jndi.toolkit.BasicWLContext_WLStub.lookup(
     at weblogic.jndi.toolkit.WLContextStub.lookup(
     at javax.naming.InitialContext.lookup(
     at com.opus.epg.classes.utils.EpgApplicationContext.lookup(
     at com.opus.epg.classes.wi.EpgNavigationController.getInstance(
     at com.opus.epg.servlets.wi.EpgControllerServlet.init(
     at weblogic.servlet.internal.ServletStubImpl.createServlet(
     at weblogic.servlet.internal.ServletStubImpl.createInstances(
     at weblogic.servlet.internal.ServletStubImpl.prepareServlet(
     at weblogic.servlet.internal.ServletStubImpl.getServlet(
     at weblogic.servlet.internal.ServletStubImpl.invokeServlet(
     at weblogic.servlet.internal.ServletContextImpl.invokeServlet(
     at weblogic.servlet.internal.ServletContextImpl.invokeServlet(
     at weblogic.servlet.internal.ServletContextManager.invokeServlet(
     at weblogic.socket.MuxableSocketHTTP.invokeServlet(
     at weblogic.socket.MuxableSocketHTTP.execute(
    I turned on the "-verbose" option while running the server. I find that the class AdminSystemHome is not being loaded. I have placed the jar containing the Home and the remote interfaces in the weblogic\myserver\serverclasses directory and specified path in the weblogic classpath .
    I also tried to put the jar in the system class path so that it might be loaded by the System classloader , but that doesnt work too.
    I also tried moving the jar to the weblogic\myserver\servletclasses directory so that it might be loaded by the Servlet class loader, but that also does'nt seem to work.
    Is there some way by which I can get the stubs downloaded at runtime so that the Network class loader loads them?

  2. Client Jar Problem (Weblogic 5.1)[ Go to top ]

    Hi Ashutosh
     you have to put the home/remote stub at the client side in addition to your class files(home and remote).