Managed Server Fails

Discussions

EJB programming & troubleshooting: Managed Server Fails

  1. Managed Server Fails (1 messages)

    I created Admin servers and Managed servers in two machines and control on the Managed servers are done by Admin servers. MachineA admin server controls 2 Managed servers in MachineB and MachineB admin server controls 2 Managed servers in MachineA When I try to start the ManagedServer2 (Which is in Machine B) which points to the Admin server of MachineA, it gives the following error.


    ************************************************************************************************************************************************************************************************* weblogic@schweb03 # ./ManagedServer2.sh p1= ManagedServer2 p2= http://MachineA:1100 LD_LIBRARY_PATH=/usr/lib:/usr/openwin/lib:/usr/dt/lib:/data0/weblogic/wlserver6.1/lib/solaris:/data0/weblogic/wlserver6.1/lib/solaris/oci816_8

    *************************************************** * To start WebLogic Server, use the password * * assigned to the system user. The system * * username and password must also be used to * * access the WebLogic Server console from a web * * browser. * *************************************************** Starting WebLogic Server .... Connecting to http://MachineA:1100... *************************************************************************** The WebLogic Server did not start up properly. Exception raised: weblogic.management.configuration.ConfigurationException: connecting to http://schweb02:1100/wl_management_internal2/Bootstrap - with nested exception: [weblogic.net.http.HttpUnauthorizedException: 401] weblogic.net.http.HttpUnauthorizedException: 401 at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:338) at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:230) at weblogic.management.Admin.getBootstrapLocalServer(Admin.java:990) at weblogic.management.Admin.initialize(Admin.java:320) at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:359) at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:202) at weblogic.Server.main(Server.java:35) --------------- nested within: ------------------ weblogic.management.configuration.ConfigurationException: connecting to http://schweb02:1100/wl_management_internal2/Bootstrap - with nested exception: [weblogic.net.http.HttpUnauthorizedException: 401] at weblogic.management.Admin.getBootstrapLocalServer(Admin.java:1081) at weblogic.management.Admin.initialize(Admin.java:320) at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:359) at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:202) at weblogic.Server.main(Server.java:35) Reason: Fatal initialization exception *************************************************************************** *********************************************************************************************************************************************************************************************

    After seeing this exception, I changed the system password inside the startDeploySL2.sh and start again, Now it gives this exception.

    ***********************************************************************************************************************************************************************************************

    weblogic@schweb03 # ./ManagedServer2.sh p1= ManagedServer2 p2= http://MachineA:1100 LD_LIBRARY_PATH=/usr/lib:/usr/openwin/lib:/usr/dt/lib:/data0/weblogic/wlserver6.1/lib/solaris:/data0/weblogic/wlserver6.1/lib/solaris/oci816_8

    *************************************************** * To start WebLogic Server, use the password * * assigned to the system user. The system * * username and password must also be used to * * access the WebLogic Server console from a web * * browser. * *************************************************** Starting WebLogic Server .... Connecting to http://MachineA:1100... *************************************************************************** The WebLogic Server did not start up properly. Exception raised: weblogic.management.configuration.ConfigurationException: DeployServerSL2 not found weblogic.management.configuration.ConfigurationException: DeployServerSL2 not found at weblogic.management.Admin.getBootstrapLocalServer(Admin.java:1001) at weblogic.management.Admin.initialize(Admin.java:320) at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:359) at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:202) at weblogic.Server.main(Server.java:35) Reason: Fatal initialization exception ***************************************************************************

    Anyone can guide me how to solve this issue?

    Thanks
  2. Managed Server Fails[ Go to top ]

    hi Lawrence

    Here are my Opinion about u r WebLogic Domain confiuration.

    check out u r configured correctly the "startManagedWebLogic.cmd" file in Machine B for the admin server in Machine A.

    If entries in "startManagedWebLogic.cmd" in Machine B is wrong , at this time it will throw throw the "weblogic.management.configuration.ConfigurationException"

    Check out While u r Starting the Managed Server in Machine B, the Admin Server Should Run in the Machine A.

    If u r try to Starting the Managed Server Remotely, check out the Node Manager is Configured Properly and Started.

    Thanks
    by
    B.SaravanaKumar