Loading Servlet from JavaWebServer2.0 GUI Administration tool?.

Discussions

Web tier: servlets, JSP, Web frameworks: Loading Servlet from JavaWebServer2.0 GUI Administration tool?.

  1. Hi,
    I have a problem in loading Servlet through JavaWebserver2.0 ADMINISTRATION TOOL(GUI).I have compiled the servlet sucessfully and placed the .class file in the folder c:/JavaWebServer2.0/servlets/sunexamples and configured properly in JavaWebServer2.0 Administration tool by giving the actual .class name including the package
    sunexamples.BasicServlet,but I get an error message problem stating cannot
    cannot update BasicServlet
    cannot find class for BasicServlet
    could not load BasicServlet
    Can anyone figureout what's the problem.Other servlets in sunexamples are working fine.
    Thanks in Advance.
  2. Place your Servlet in Servlets folder not in the sunexamples
    and then give in the path Servlets.abc.class
    I think this will solve your problem.
  3. It did not work either.I guess there might be a problem of configuration in JWS2.0 B'COS it is not loading the Servlet.
    Even I have tried including the package,I have also used
    Unique name for my servlet and given the actual .class name in CONFIGURATION ADD MENU which navigates to another screen for Description of servlet,though optional and the second column asking for class.This is the point Where I give path and my servletname not the actual .class (servlet compiled) and also the package if any.But I am not able to load the servlet as the server is not finding the servlet class.
    Even I tried shutting down the server couple of times to ensure the avoiding cache problem.
     Any Suggestions please!
    Thanks
  4. I got the problem solved finally.It is in giving the right package name and calling from the HTML FORM ACTION and also saving and loading from the JAVA ADMINISTRATION TOOL.
    Anyway lots of confusion at this point.
    Thanks again.