SAXException: No deserializer for (urn:xyz)Product


XML & Web services: SAXException: No deserializer for (urn:xyz)Product

  1. Hello,

    I have an RPC style web service deployed. one of the methods in my web service returns a Hashtable containing Product java-beans.

    When I'm trying to invoke this method, it's throwing this SAXException stating it could not find the deseializer.

    I had also mentioned the deployment descriptor in the following manner.

    <beanMapping qname="catalogNS:Product" languageSpecificType="java:de.freenet.productcatalog.beans.Product" serializer="org.apache.axis.encoding.ser.BeanSerializerFactory" deserializer="org.apache.axis.encoding.ser.BeanDeserializerFactory"/>

    I even set the the serializer and deserializer on call object using registerTypeMapping(...);

    can any one please throw some light on this??

    Thanks in advance,

  2. I assume you are using Apache Axis. Can you show you wsdd config for the bean and your BeanSerializerFactory, BeanDeserializerFactory, and registerType Mapping code?

  3. Hello Jason,

    I'm sorry, not to have provided enough information..

    I'm using Apache Axis 1.1 with Tomcat 4.1.29.
    QName productqn = new QName("urn:RemoteProductCatalogWebService","Product");

    I tried the following 3 ways... none works.

    call.registerTypeMapping(Product.class,productqn,new BeanSerializerFactory(Product.class,productqn),new BeanDeserializerFactory(Product.class,productqn),false);

    call.registerTypeMapping(Product.class,productqn,new BeanSerializerFactory(Product.class,productqn),new BeanDeserializerFactory(Product.class,productqn));

    and I'm not sure about the wsdd Config you mentioned.

    it'll really be helpful if you could suggest me how should I go ahead.

    Thanks in Advance,

    call.registerTypeMapping(Product.class,productqn,BeanSerializerFactory.class, BeanDeserializerFactory.class);
  4. Hello Jason,

    I figured it out. i was using the wron namespace.. when I changed it .. it works fine.

    Thanks any way for your efforts.

  5. Hi Pavan,

    I am experiencing the same problem as you encountered. Could you let me know how you fixed it. I am not sure what you meant by when you said you fixed the namespace.