JSSE problems with IBM JVM on AIX


General J2EE: JSSE problems with IBM JVM on AIX

  1. JSSE problems with IBM JVM on AIX (1 messages)

    I've a configuration problem with JSSE using IBM JRE for aix, JVM version info follows:
    ... > ./java -version
    java version "1.4.2"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
    Classic VM (build 1.4.2, J2RE 1.4.2 IBM AIX build ca142-20040917 (JIT enabled: jitc))

    I'm running JBoss 3.2.1+Tomcat 4.1.24 with HTTPS configured but when jboss starts up it gives me the following error:
    2004-11-03 09:56:48,708 ERROR [org.jboss.security.ssl.DomainServerSocketFactory] Failed to get SSLContext for TLS algorithm
    java.security.NoSuchAlgorithmException: Class com.ibm.jsse.bq configured for SSLContext not a SSLContext
    at com.sun.net.ssl.SunJSSE_b.a(DashoA6275)
    at com.sun.net.ssl.SSLContext.getInstance(DashoA6275)
    at org.jboss.security.ssl.DomainServerSocketFactory.initSSLContext(DomainServerSocketFactory.java:174)
    at org.jboss.security.ssl.DomainServerSocketFactory.createServerSocket(DomainServerSocketFactory.java:107)
    at org.jboss.web.catalina.security.SSLServerSocketFactory.createSocket(SSLServerSocketFactory.java:74)
    at org.jboss.web.catalina.security.SSLServerSocketFactory.createSocket(SSLServerSocketFactory.java:57)
    at org.apache.catalina.connector.http.HttpConnector.open(HttpConnector.java:978)
    at org.apache.catalina.connector.http.HttpConnector.initialize(HttpConnector.java:1187)
    at org.apache.catalina.startup.Embedded.start(Embedded.java:999)

    then I tried to move to Sun JSSE copying jsse.jar, jnet.jar and jcert.jar from JBoss dist tree (they were placed in serve/default/lib) in jre/lib/ext dir but I got the same result. I also tried to specify JSSE_HOME: same results.

    Any idea?
  2. JSSE problems with IBM JVM on AIX[ Go to top ]

    You need to use IBMJSSE and not Sun's version when using the IBM JDK.