IBM Websphere 3.02 with JDK 1.2 support

Discussions

EJB programming & troubleshooting: IBM Websphere 3.02 with JDK 1.2 support

  1. IBM Websphere 3.02 with JDK 1.2 support (2 messages)

    Hi,
    I would appreciate if you could help me out with the following query.

    We wish to work with Websphere Application Server 3.0.2. Our current
    application is coded in JDK 1.2 whereas Websphere Application Server 3.0.2
    uses JDK 1.1.7. There is a diference in both JDK versions. We need to
    migrate our application from the current App Server ie. from Jonas 2.1 to
    WebSphere. Could you please help us out and tell us what needs to be done in
    such a situation to take care of the JDK version conflict.

    Thanks in anticipation,
    Wilma



  2. recompile all ur java files under jdk 1.1.7
  3. Hi Amol, Thanx for the response.

    U said to compile all the files under JDK 1.1.7, but how will u compile files written in JDK 1.2 as they have some functions which are not there in JDK 1.1.7 like the deleteCharAt() method of StringBuffer class is present only in JDK 1.2 onwards.
     
    What do u do in that case?

    Regards,
    Aniket.