Calling Jboss 4.2.2 EJB (2.0) from Weblogic 8.1


EJB programming & troubleshooting: Calling Jboss 4.2.2 EJB (2.0) from Weblogic 8.1

  1. Calling Jboss 4.2.2 EJB (2.0) from Weblogic 8.1 (5 messages)

    Hi, I have the following environment Weblogic 8.1 and JBOSS 4.2.2. Because the two server uses different JDKs 1.4.2 vs 1.5, I run into various class version issues when I try to incorporate jboss classes to run in weblogic. I want to use a EJB 2.0 in jboss so that my weblogic 8.1 can call but I am afraid the jboss jndi context factory is in jdk 1.5 so it can't be used in weblogic 8.1. Does anyone know if I can use an older version of the jboss context factory (jdk1.4) to use inside weblogic to call the jboss ejb? Just thought I scope experience before I waste time trying things out. Thanks Richard
  2. Intresting.. I think the client should have to match the server JDK version. There might be a issue when the WL server expects the object of different version and would get a different one. Please let me know how it worked out.
  3. In fact this is an issue not necessarily weblogic/jboss but jdk 1.4 / jdk 1.5. Weblogic runs on jdk 1.4 and (by old information from Bea) is NOT compatible with jdk 1.5. On the other hand JBossAS 4.2.2 requires jdk 1.5 and up and the client is compiled with 1.5 so if you try to simply use the 4.2.x client classes in WL8.1 you'll most likely get a major minor error. Ok so let's try to use the 4.0.x client to access 4.2.x... oops no go! JBossAS uses JBoss Remoting to handle the transport and the version that is shipped with the 4.0.x client is 1.4.x while the version that is shipped with 4.2.x is 2.2.x and the two don't seem to like talking to each other! BUT! Not all news is bad! JBoss Remoting has an intermediate version 2.0.x that doesn't seem to have shipped either with AS4.0.x nor 4.2.x and here we have our salvation! If we package JBRemoting 2.0.0.GA (which seems to have been compiled with 1.4.2) and the jnp-client.jar from 4.0.x we are able to call 2.1 EJB's that are hosted in the JBossAS 4.2.x from a jdk 1.4.2, and hence from WL8.1
  4. a bit more info: The complete list of jar required for normal JNDI (port 1099, not HA port 1100) is as follows: concurrent.jar jboss-client.jar jboss-common-client.jar jboss-j2ee.jar jboss-remoting.jar jboss-serialization.jar jboss-transaction-client.jar jbosssx-client.jar jnp-client.jar
  5. for access to the HA JNDI naming service (ie port 1100) you need to add the jbossha-client.jar also
  6. jboss-remoting 2.0.0.GA has a problem... when the socket timesout the next call causes an exception. However 2.2.0.GA seems to have the issue corrected and was also compiled with 1.4.2 so it works.