Discussions

General J2EE: How to debug servlet on Websphere?

  1. How to debug servlet on Websphere? (3 messages)

    I put this string into the JVM param on Websphere 4: "-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,address=5000,suspend=n", and I try to debug on port 5000 in eclipse, but there is no response, and all the step button in eclipse's debug perspective is grey... what can I do?

    If I use MyEclipse and Lamboz plugin in eclipse, how to setup them to integrate eclipse with Websphere 4?

    Threaded Messages (3)

  2. by the way[ Go to top ]

    my computer doesn't allow me to run WSAD, so, can you just give me some tips of what is about eclipse:)
  3. I debug using the same parameters (different port) and I've got no problems although I do not use LOMBOZ. Make sure you put the parameters in JVM Settings | Advanced JVM Settings | Debug String.

    Kalin
  4. thanks for helping:)[ Go to top ]

    but i still cannot solve the problem...i use the same settings as yours in WAS4 -> JVM settings -> Advanced JVM settings -> Debug String. but when i start debugging, although the debugging seems to be processing, it seems it has not suspended at my breakpoint. and there are many threads in the debug perspective, with no console output and no variables output, and the step buttons is grey(disabled)...what is wrong?

    i try to debug as Remote Java Application, and i add WebSphere/AppServer/lib/bootstrap.jar and WebSphere/AppServer/lib/j2ee.jar to Source. what further steps should i take? am i right?

    thanks a lot!