Discussions

EJB design: Exception In Creating Connection Pool On WLS 7.0

  1. Exception In Creating Connection Pool On WLS 7.0 (3 messages)

    Dear All,

         I am trying to create a Connection Pool on WLS 7.0. For this i had followed the follwoing steps.

    1)Name : "Sample Pool"
    2)URL : jdbc:weblogic:mssqlserver4:SMSXCELL@NXL-TEC-11:1433
    3)Driver ClassName : weblogic.jdbc.mssqlserver4.Driver
    4)Properties : user=sa,password=sa
    5)ACL Name :
    6)password :
    7)Open String Pwd :

    with the above configuration, i tried to create the connection pool. But i am getting the exception on the console as

    <Cannot startup connection pool "samplePool" weblogic.common.ResourceException: weblogic.common.ResourceException:
    Could not create pool connection. The DBMS driver exception was:
    java.sql.SQLException: Login failed for user 'sa'. Reason: Not associated with a
    trusted SQL Server connection. Severity 14, State 1, Procedure 'null null',
    Line 0 Unable to connect, please check your server's version and availability.


    Advance congrats to those who Can solve the above stated problem.

    Regards,
    Saradhi.
  2. Dear All,

    >
    >      I am trying to create a Connection Pool on WLS 7.0. For this i had followed the follwoing steps.
    >
    > 1)Name : "Sample Pool"
    > 2)URL : jdbc:weblogic:mssqlserver4:SMSXCELL@NXL-TEC-11:1433
    > 3)Driver ClassName : weblogic.jdbc.mssqlserver4.Driver
    > 4)Properties : user=sa,password=sa
    > 5)ACL Name :
    > 6)password :
    > 7)Open String Pwd :
    >
    > with the above configuration, i tried to create the connection pool. But i am getting the exception on the console as
    >
    > <Cannot startup connection pool "samplePool" weblogic.common.ResourceException: weblogic.common.ResourceException:
    > Could not create pool connection. The DBMS driver exception was:
    > java.sql.SQLException: Login failed for user 'sa'. Reason: Not associated with a
    > trusted SQL Server connection. Severity 14, State 1, Procedure 'null null',
    > Line 0 Unable to connect, please check your server's version and availability.
    >
    >
    > Advance congrats to those who Can solve the above stated problem.
    >
    > Regards,
    > Saradhi.


    Remove the comma between user and password properties. Add password in next line or separate by ;
  3. Dear Sir,
     I had created the user and password fields in seperate lines. Kindly suggest some other solution.

    Regards,
    Saradhi.
  4. You don't say what version of SQL Server you're using. If it's SQL Server 2000, then you have to set the properties as follows:

    sql7=true;user=sa;password=sa

    Note that the separator in the properties is a semi-colon, not a comma. This worked for me so hopefully it will work for you too.