Discussions

Web tier: servlets, JSP, Web frameworks: web servers supporting struts

  1. web servers supporting struts (2 messages)

    Hi,
    Could anyone please point out any web resource that details the web servers that support struts?

    Would it be nice to assume that all web servers that support servlets also support struts?

    Are there any web resources that deal with these kind of struts deployment questions?

    TIA,
    Babu
  2. Could anyone please point out any web resource that details the web servers that support struts?
    As per the Struts user guide,

    Servlet Container - You must download and install a servlet container that is compatible with the Servlet API Specification, version 2.2 or later, and the JavaServer Pages (JSP) Specification, version 1.1 or later. One popular choice is to download Apache's Tomcat (version 3.1 or later required, version 3.3 or later recommended).

    hope that helps
    Venkata Allamsetty
  3. Thanks for the clarification.

    Apart from Tomcat are there any other web servers that confirm to the servlet API specification and the JSP spec?

    Any web resources dealing with the web servers supporting struts will be of much use.

    TIA,
    Babu