How to compile the EJB with the new versions of jdk when old versions are running in weblogic server. Ever time I compile the EJB there is a problem with warning messages and deployment at the server it's says problem with the some class though it's correct. compiling with new versions of jdk will work in older versions ,In my case weblogic 7(jdk1.3) and I compiled with jdk 1.5. Tried to my level best.... Any help would be appreciated? Thanks & regards, Archana