J2EE Compliant WebSphere 4.0 developers edition announced

Discussions

News: J2EE Compliant WebSphere 4.0 developers edition announced

  1. WAS 4.0 Std is J2EE certified, supports EAR and WAR files, full XML descriptors for all beans (CMP,BMP and Session beans) runs on JRE 1.3, supports EJB 1.1, Servlet 2.2 and JSP 1.1. It uses XML files for all its system configuration needs so no more database for configuration a la WAS 3.5/3.0

    It also includes an embedded XML/XSL parser and SOAP/UDDI support, I guess we'll need to get our hands on it to see what this really means.

    It's seems to be free for developers use and is available on Windows NT/2000 at this point, expect other platforms to follow.

    This is intended to be the developer release of WAS 4.0. WAS 4.0 Advanced is what they want you to use for production and that won't be free, of course :=(

    The difference between Std and Advanced seems to be Std has limited security support and no clustering/load balancing.

    You can see Suns J2EE test results here.

    You need to contact your IBM rep to get a copy.

    IBM WebSphere Technology Edition for Developers..
    WebSphere 4.0 available for S/390.
  2. Sounds good, when the war is settled they become finally full J2EE compliant and not almost, is there any patch available for VAJ 3.5.
    BTW WebSphere 3.5.3 already supports EJB1.1 etc.
  3. yes
  4. Hi Billy
    How can one get a evaluation copy of the new websphere 4.0 for win nt or windows 2000. Is it available for download on the IBM's site. Could u plz post the link if it is available for download.

    thanks
    Bikram Bajwa