Discussions

EJB programming & troubleshooting: MaxStackMemoryMB

  1. MaxStackMemoryMB (2 messages)

    I am configuring Websphere 7 and trying to limit the amount of memory my server uses. Does anyone wheter MaxStackMemoryMB is a JVM or an WebSphere setting? I get an exception: Caused by: com.ibm.ws.dcs.common.config.DCSWrongConfigParamValueException: The value of parameter MaxStackMemoryMB is 100, whereas the maximum of this parameter is 48 The JVM is Java version = 1.6.0, Java Compiler = j9jit24, Java VM name = IBM J9 VM
  2. Hi, I think I faced the same problem and solved it. In fact this error is linked with Core Group settings: for some reason you can't set core group "transport memory size" to more than the "JVM memory" (see https://was-sbxlyon44.vitfr.volvo.net:9043/ibm/help/index.jsp?topic=/com.ibm.ws.console.highavailabilitymgmt/urun_ha_cgdetail.html). I thought the "JVM" they're referring to was the one from the server hosting core group coordinator, but it seems it is not (I tried forcing it to a specific server and that didn't help). Anyway, you are probably trying to start an application server with 48Mo of JVM memory, while the core group transport memory size is 100. So you need to either: - lower the core group transport memory size to 48 - increase your AS memory size to 100 I suppose you prefer first solution: Go to Core Groups / Core Groups settings / Default Core Group, and change transport memory size value. Note: I discovered the maximum value is not exactly the JVM value! I had a JVM of 64 and had to lower core group transport memory size to... 62! Olivier
  3. Hi, I think I faced the same problem and solved it. In fact this error is linked with Core Group settings: for some reason you can't set core group "transport memory size" to more than the "JVM memory" (see https://was-sbxlyon44.vitfr.volvo.net:9043/ibm/help/index.jsp?topic=/com.ibm.ws.console.highavailabilitymgmt/urun_ha_cgdetail.html). I thought the "JVM" they're referring to was the one from the server hosting core group coordinator, but it seems it is not (I tried forcing it to a specific server and that didn't help). Anyway, you are probably trying to start an application server with 48Mo of JVM memory, while the core group transport memory size is 100. So you need to either: - lower the core group transport memory size to 48 - increase your AS memory size to 100 I suppose you prefer first solution: Go to Core Groups / Core Groups settings / Default Core Group, and change transport memory size value. Note: I discovered the maximum value is not exactly the JVM value! I had a JVM of 64 and had to lower core group transport memory size to... 62! Olivier

    Thanks Olivier! Thanks to you my AS has finally started!