JFrog is proud to announce the release of the new Bamboo Artifactory Plugin. This version of the plugin introduces a new Gradle builder that brings full support for running Gradle builds inside Bamboo, complete with Build Info Integration and automated artifact deployment and resolution from/to the Artifactory binary repository.
 
The Bamboo Artifactory Plugin is now also compatible with Bamboo 2.7.x, including support for multiple build steps.

Another significant improvement is the ability to specify custom artifact and descriptor patterns for Ivy builds, which are also supported by the plugin (along with Maven builds).

Requirements:

  • Artifactory 2.2.5 or later. For best results and optimized communication it is recommended to use the latest version of Artifactory. Artifactory Pro is required for advanced features, such as License Control and enhanced Build Integration.
  • Atlassian Bamboo 2.6.0 or later running on JDK 1.6 or later.
  • Gradle 0.9 or later.
  • Maven 3.
  • Ant + Ivy 2.1.0 or later.

More information and installation instructions are available on the JFrog wiki.

Enjoy!

The Artifactory Team