Problem serving images from WebLogic 5.1 sp8

Discussions

Web tier: servlets, JSP, Web frameworks: Problem serving images from WebLogic 5.1 sp8

  1. Hi.

    I have WL5.1 installed and setup properly. Am using it to serve some jsp pages. All that is working fine.

    I have a header.jsp and a footer.jsp pages that I include in the other pages via
    <jsp:include page="header.jsp"/>

    They get included fine, but if I have any archors to images in the .jsp's the browser is unable to download the images.
    I have noticed that I cannot access the images directly even if I enter their url correctly.

    I am able to view the .jsps but not the images they refer to!?
    Any one got any ideas?

    thanks!
  2. Figured it out.

    I had to enable the default file servlet on the weblogic.properties.

    Works great now!

  3. Hi,
    i am using web macro (www.webmacro.org) as my front end with servlets as back end for my application, i have a standard header file in webmacro in which the images are not loading, i am able to get the the contents of my standard_hearder.wm, which serves as a header, but has any one worked before with web macro's as front end using weblogic, i am able to get access to the std_header.wm template contents but not the images, the basic question is how does weblogic load the images which need to be in a different folder rather than public_html\images or public_html\servletImages, any help would be greatly appreciated

    thanks again for ur time
    Bhargav