why my 'ant' is not running


General J2EE: why my 'ant' is not running

  1. why my 'ant' is not running (5 messages)

      After installing ant1.6.1 when i am trying to run the commant 'ant' it shows the following exception..

    java.lang.InstantiationException: org.apache.tools.ant.Main
            at java.lang.Class.newInstance0(Class.java:293)
            at java.lang.Class.newInstance(Class.java:261)
            at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
            at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)




    Threaded Messages (5)

  2. why my 'ant' is not running[ Go to top ]

    Hi,  After installing ant1.6.1 when i am trying to run the commant 'ant' it shows the following exception..java.lang.InstantiationException: org.apache.tools.ant.Main        at java.lang.Class.newInstance0(Class.java:293)        at java.lang.Class.newInstance(Class.java:261)        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)why??Regards,MaRu.
    Create a .bat file and set ant path where it is installed in it. like
    set ANT_HOME=d:\jwsdp-1.3\apache-ant
    set PATH=%PATH%;%ANT_HOME%\bin
    and then go to the folder where you ant is and type ant.
  3. why my 'ant' is not running[ Go to top ]

    Still I am getting the same problem..
    what to do :(
  4. why my 'ant' is not running[ Go to top ]

    I was also getting the same problem
    Foll. worked for me..
    Instead of unsetting the classpath , try to put
    at the beginning of your classpath. I encountered the exact same problem under w2k and after setting the
    classpath to CLASSPATH=$ANT_HOME/lib;$CLASSPATH; ant worked without errors :-). But it is necessary that you put the ANT-Path at the beginning of classpath. Any other JDK-Path at the beginning results in the described error....

  5. why my 'ant' is not running[ Go to top ]

    ThanQ Purvesh Vora,

     It is successfully working...
  6. Error in running ant[ Go to top ]

    Hello All,


    I have sent path, ANT_HOME as well in my system. But still I am not able to run my ant. whenever I am running ant its giving error as 

    "Error occurred during initialization of VM Unable to load native library: Can't find dependent libraries"...

    please anybody help me to fix this bug....thanks in advance