JBuilderX and JBoss3.2.5


EJB programming & troubleshooting: JBuilderX and JBoss3.2.5

  1. JBuilderX and JBoss3.2.5 (7 messages)

    I configure JBuilderX and JBoss3.2.5, but when I compile the classes the following error appears for different classes

    the package javax.servlet.http does not exist

    If I look the packages that must be included in JBoss it appears c:\jboss3.2.5\server\default\lib\javax.servlet.jar but this file doesn't exist. May be this is the problem, but... how can I solve it?


    Threaded Messages (7)

  2. JBuilderX and JBoss3.2.5[ Go to top ]

    Check on your Project properties what package you have configured for your project. Probably you have the JBoss 3.x+ Client package, which consists of multiple jar files. One of them should be the java.servlet.jar and might be red because JBuilder cannot find it. Remove it, and add the correct path (in <jboss>/server/all/deploy/jbossweb-tomcat.sar/servlet-api.jar.

    Hope that helps!
  3. JBuilderX and JBoss3.2.5[ Go to top ]

    I did what you told me, and now the following message appears:

    log4j:WARN No appenders could be found for logger (org.apache.jasper.compiler.JspRuntimeContext).
    log4j:WARN Please initialize the log4j system properly.

    and then a series of errors

    "areasFinderIndex.jsp": Error num.: 200 : Se esperaba <identifier>
    "areasFinderIndex.jsp": Error num.: 901 : el paquete <error> mencionado en el archivo fuente C:\Usr\Alejandra\JBuilderX\EJBCMP\classes\Generated Source\.jsp\EJBCMPWebMod\areasDelegateClient\areasDelegateClient_0002fareasFinderIndex_0002ejsp_jsp.java no corresponde con el directorio areasDelegateClient

    where areasDelegateClient is a directory where I have my .jsp

  4. JBuilderX and JBoss3.2.5[ Go to top ]

    Where does this message appear? In JBuilder (not when you're building, are you running debug or something?) or when you start of JBoss separately?
  5. JBuilderX and JBoss3.2.5[ Go to top ]

    Inside the JBuilderX when I build
  6. JBuilderX and JBoss3.2.5[ Go to top ]

    To be honest I've switched off building the JSP pages from within JBuilder, and let JBoss do that when I deploy. Perhaps that's not what you want, but it will probably solve the problems you see for now anyway.
  7. JBuilderX and JBoss3.2.5[ Go to top ]

    I couldn't find a way to solve it from JBuilderX, but as you suggested I run it from outside and it worked.

    Thanks a lot
  8. JBuilderX and JBoss3.2.5[ Go to top ]

    Man... I solveit.

    Goto Properties of warfile.
    Select knot "Web" and type in "Launch URI: ": "/".

    Only that!