Problem with Oracle 10g JDBC


General J2EE: Problem with Oracle 10g JDBC

  1. Problem with Oracle 10g JDBC (2 messages)


    I was working fine with 9i JDBC ( dirver). But 10g gives me connection time out. I already downloaded ojdbc14.jar dirver for 10g.

    java.sql.SQLException: ORA-12170: TNS:Connect timeout occurred

    ORA-12170: TNS:Connect timeout occurred



    Threaded Messages (2)

  2. Problem with Oracle 10g JDBC[ Go to top ]

    Have you tried with classes12.jar 10g version?

  3. Oracle driver confusion[ Go to top ]

     JDBC 2.1 compliant
     Only for JVM 1.2, 1.3

     JDBC 3.0 compliant
     Only for JVM 1.4

    If you run JVM 1.5, use ojdbc14.jar as well. I don't think the JDBC API was updated for 1.5, and thus no driver update.

    You should always pick the driver based on the version of the VM.

    This is just information I've gathered. I started looking when I had issues with BLOB handeling that worked fine on a machine for about a week, then crashed. Also there are some strange connection issues that I've run into.