Classpath Query


General J2EE: Classpath Query

  1. Classpath Query (3 messages)

    I have a Stateless session bean which use few other external packages assume a.jar b.jar. I don't want to give this in classpath. I have bundled this in the ear file inside my classes directory. When i deploy the ear i get

    How can i fix this problem without include a.jar and b.jar in my classpath.

    I am using weblogic in a solaris box


    Threaded Messages (3)

  2. Classpath Query[ Go to top ]

    I could not understand your mail completely. The thing is if u dont want to put them in server class path then its fine no issue..

    Make the entry in application.xml and an entry in the bean manifest file like following:


    2)jar manifest ->
    Class-path: <jar-file-name>

    Try, if any issue let me know.

  3. Classpath Query[ Go to top ]

    Yeah, What you have understood is clear... I am trying to achive that only.. I tried out the way you said But while deploying i am getting the below error

    my application.xml has :
    <!DOCTYPE application PUBLIC '-//Sun Microsystems, Inc.//DTD J2EE Application 1.2//EN' ''>

    and My file has
    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.6.2
    Created-By: 1.3.1_08-b03 (Sun Microsystems Inc.)
    Class-path:xerces.jar jaxen-full.jar

    Below is the error message.. Anything else i need to do pls let me know..


    Unable to deploy EJB: InitialTaskAssignment from InitialTaskAssignment.jar:

    at java.lang.Class.newInstance0(Native Method)
    at java.lang.Class.newInstance(
    at weblogic.ejb20.deployer.ClientDrivenBeanInfoImpl.prepare(
    at weblogic.ejb20.deployer.EJBDeployer.setupBeanInfo(
    at weblogic.ejb20.deployer.EJBDeployer.prepare(
    at weblogic.ejb20.deployer.EJBModule.prepare(
    at weblogic.j2ee.J2EEApplicationContainer.prepareModule(
    at weblogic.j2ee.J2EEApplicationContainer.prepare(
    at weblogic.j2ee.J2EEApplicationContainer.prepare(
    at weblogic.drs.internal.SlaveCallbackHandler$1.execute(
    at weblogic.kernel.ExecuteThread.execute(
  4. Classpath Query[ Go to top ]

    It worked. I did it from a scratch and followed the steps you said.

    Thanks for your time