RMI Security Manager


EJB design: RMI Security Manager

  1. RMI Security Manager (6 messages)

    hi experts

    I have one small application in RMI . The problem with that application is that it fails to run over the intranet.I have RMI security manager in my code but when i try to run that application from different machine it gives me the error: java.net.socketException IP....... connect,resolve
    AccessDenied SocketException.

    what should i do to overcome this.I have gives suitable permission.may be i may have done some thiing wrong in giving permission.So ,if any one can help me in solving this will be of great help.
    thanx in advance

    Threaded Messages (6)

  2. RMI Security Manager[ Go to top ]

    It's possible that the socket is locked by another application or by your application that crashed..!!

    Change the Socket and try again.
  3. RMI Security Manager[ Go to top ]

    I have tried changing the socket but still it is giving me the same error.But bydefault it is taking the rmi port so i guess it is not the problem.The entire application works fine in local machine but fails over the intrenet. I have RMISecurity Managet i guess this might be the cause of the problem.

    Any suggetion will be of greate help
  4. RMI Security Manager[ Go to top ]

    if u have something in ur client code
    //System.setSecurityManager(new java.rmi.RMISecurityManager());

    just comment as above .
    i think if u comment it should work. don't set any securities to ur client.
  5. RMI Security Manager[ Go to top ]

    Be carefull if you are downloading the servant Stub or not.
    If you are, the RMISecurityManager will be necessary and obrigatory. Now if the Stub is local in the client machine, you won´t need that.
    You should open the rmiregistry door, I think that it is 1099, I´m not sure. Or if you are in a developmente environment, just open you security configurations, for funcionality tests, and later you could look for what is the right door that must be openned.

    Marcelo Santiago Guedes
  6. RMI Security Manager[ Go to top ]


    But how do i open the security? I have set the desired permission in the java policy file but i may be wrong in doin so, may be my syntax is wrong . The reason is it works fine in local machine but does not run in different machines.

    I would ne so nice of u if u give me the exact syntax for setting the desired security.
  7. RMI Security Manager[ Go to top ]

    check your naming service - it's on same process , or it's rmiregistry ?