Home

News: Java security patch breaks Guava library

  1. Java security patch breaks Guava library (1 messages)

    A small security fix in Java update 51,released last week, appears to be incompatible with the popular Google Guava library.

    However, Oracle have so far refused to revert the change, which according to the changelogs was meant to “enhance generic classes”.

    Read the full article here.

  2. I don't think Oracle need to make itself backwards compatible with every java library in existence when it releases a version of the JDK. Guava has to fix itself.