J2EE RI giving NoClassDefError

Discussions

EJB programming & troubleshooting: J2EE RI giving NoClassDefError

  1. J2EE RI giving NoClassDefError (1 messages)

    I am running J2EE RI 1.3 beta 2 (downloaded 7/5/01) on Win 2000 Pro. Using the Deploy Tool.

    Here's the problem:

    I have an EJB that uses several support classes. I have tried packaging the additional classes in three different ways:

    1. Put them in a library jar, load that jar into my EAR, add the jar to the manifest classpath for the bean jar.

    2. Load the class files directly into the bean jar from a directory.

    3. Put the classes directly in the J2EE server's class path.

    In case 1, the J2EE server gives a NoClassDefFoundError the first time it tries to access one of the support classes.

    In case 2 I get the same error IF the classes are loaded into the bean jar from a directory NOT in the classpath of the deploytool, but NOT if I move the classes into the deploy tool classpath and load them from there. Same class files! Only difference is where they resided when I selected them in the deploy tool.

    Case 3 works fine.

    Am I doing something wrong with the deploy tool? (Can't think what.) Is there a bug? (No mention of this in JavaSoft's J2EE "Bug Parade".) Am I crazy? (I hope not!)

    Please help. Thanks

    David Herst
  2. Hello,
    I think you must be using xyz.ser java Serialized Class
    then You must put that ejb jar file in weblogic_classpath in startweblogic.cmd file and restart the weblogic server.

    bye
    from
    Ram Mohan,
    Oxygen Networks,
    Hyderabad, India.