Discussions

EJB design: Deciding between EJB 1.0 or EJB 1.1

  1. Deciding between EJB 1.0 or EJB 1.1 (2 messages)

    I am writing an application using VAJ and WAS 4.0. The problem i found is that VAJ does not support EJB 1.1 as claimed. What it exports as EJB 1.1 seems some hybrid version of EJB 1.0 and 1.1. Now what should I do
    1. Use EJB 1.0
    2. Use hybrid of 1.0 & 1.1
    3. Use EJB 1.1 (and how)
    any comments are welcome

    Thanks in advance

    Hassan
  2. EJB 2.0 has been released for a while now.
    It means EJB 1.0 is really a bit obsolete .

    If you start a new development, my opinion is that it is not a good idea to use 1.0.

    You should better use 1.1 or 2.0.


    My $0.02
  3. This is really confusing weather websphere supports EJB1.1 or EJB1.0 are you sure about it !

    please can any one ask IBM gusy what they are doing about it ,can they solve this mess??

    Cheers
    Manoj